Audiohub 2x4 - Audio troubleshooting guide

This applies to the Audiohub 2x4

If you are experienceing audio problems with your Audiohub 2x4 such as unwanted audio artefacts, audio dropouts or glitches, there are several steps you can take to troubleshoot this and try to resolve the problems.

First of all, for optimum audio performance, Novation recommend connecting the incuded power supply to the Audiohub to avoid unwanted audio artefacts.

With any audio interface, you must trade performance/latency for stability. When connected via a hub, this trade off is less favourable and Audiohub is an audio interface connected via an internal hub. As a result of this, if you're still experiencing audio problems, please try running your Audiohub at a sample rate of 44.1kHz as opposed to higher sample rates such as 88.2kHz or 96kHz.

To do this on Windows, open your DAW audio preferences and you will find an option to change the sample rate. Please ensure this is set to '44.1kHz', '44100Hz' or similar.

To do this on a Mac, open 'Audio MIDI setup', select the 'Audiohub 2x4' and set the 'Format:' to '44100.0 Hz' as shown in the below screenshot:

Audiohub Audio MIDI Setup


If you continue to have audio problems, please try increasing your Audiohub audio buffer size.

To do this on Windows, you should open the 'Audiohub USB 2.0 Audio Control Panel', set the 'USB performance mode' to 'Mixing' and click 'Apply' as shown below:

Audiohub USB 2 Audio Control Panel


On Mac, you can set your buffer size in your DAW audio preferences. The Screenshot below shows where this can be set in Ableton Live. Try setting this to 512 or 1024 to see if it helps:

Audiohub Ableton preferences


If you continue to have problems, please submit a case to our support team here.

Was this article helpful?
0 out of 1 found this helpful
Have more questions? Submit a request